Invader

Any questions? We will try and help.
screwit
Posts: 948
Joined: 09 Apr 2010, 21:29
Location: Stratford vic

Re: Invader

Postby screwit » 23 Sep 2018, 09:28

Well after a good run at the VSBC 70th and having the steering cable pull through two cable clamps was time to replace the cracked quadrent .
A new one was made and fitted and a new cable fitted and rerouted to join on the side of the cockpit.
When fitting the rudder it was found to be warped from heat so 25mm was cut off the bottom to fix that .
Next was to try a different prop l got from a swap meet with a light mounted on it !
Test run on friday reveiled the boat no longer listing to the rh side at higher rpm but listing a little to the left at high speed and running higher revs at same speed.
Prop was a 9 3/4 diamiter 3 blade with more pitch than the two blade l was running.
But boat was much better to steer and didnt need to hang on at 6000 rpm .
So next step is to cut a 1/2 " off the two blade diamiter and give it another run .

User avatar
Greg
Creator
Posts: 1866
Joined: 03 Mar 2009, 08:02
Location: Central Victoria
Contact:

Re: Invader

Postby Greg » 23 Sep 2018, 20:34

Like a true skiff owner/driver Ross. Lots of trial and error and tweaking and test runs getting it all sorted out.

screwit
Posts: 948
Joined: 09 Apr 2010, 21:29
Location: Stratford vic

Re: Invader

Postby screwit » 29 Sep 2018, 19:15

Prop has been trimed to 10 1/4" and a little off the leading edge near the hub to make the blade area smaller and thinned the edges down as it was getting thicker as it was reduced in diameter.
A quick static balance and fitted ready to test.


Return to “Restoration Help and Advice”

Who is online

Users browsing this forum: No registered users and 1 guest